Updated code from OpenSound has enabled the Barracuda AC-1 in Gutsy.  You can follow my previous Feisty post to get this working.  Gutsy requires oss-linux_v4.0-1006_i368.deb or later.  And the rear speakers work now too. :-)  Hello 5.1! Enjoy.